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Microsoft Office Word 2007 
The new Word environment is designed to more closely reflect the way people generally 
work with the program. Let’s tour the new look.  
 
 
 
 

 

 

 

• Microsoft Office Button: holds commands related to managing Word and Word documents as a 
whole; replaces the File Menu that appeared in previous versions of Word. 

• Tab: holds commands related to working with document content; the Home tab is active by 
default; clicking on one of the other tabs displays that tab’s buttons. 

• Title Bar: displays the name of the active document. 
• Quick Access Toolbar: holds commands that you use often; Save, Undo, and Repeat buttons 

are active by default; you can customize the toolbar to hold any command you use frequently. 
• Group: holds organized buttons according to tabs. 
• Ribbon: below the Title Bar; makes all the capabilities of Word available in a single area. 
• Microsoft Office Word Help Button: right-hand end of the ribbon; allows you to search for Word 

help. 
• Status Bar: gives information about the current document; right click to turn on or off items that 

are displayed. 
• Dialog Box Launcher: holds related but less common commands; display by clicking at the right 

end of the group’s title bar. 
• View Toolbar: provides tools for adjusting the view of a document. 

The goal of the redesigned working environment is supposed to make features more 
accessible and visible. For example, when a formatting option has several choices, they 

Microsoft Office Button 

Tab Quick Access Toolbar
Title Group Ribbon 

Dialog Box Launcher Status Bar View 

Help Button 
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are displayed in a gallery of thumbnails. If you point to a thumbnail in a gallery, live 
preview shows you what the choice will look like if you apply it.  

As with all Office 2007 applications, the Ribbon is the biggest visual change. Instead of 
hiding in menus, functions are displayed on the Ribbon. They are grouped by tasks, and 
by clicking a tab, you can display the list of functions for that task. Instead of having to 
remember what menu something was under or what tiny button you needed to press on 
a toolbar, it is all right there for you to see. The new Ribbon groups your tools by task, 
and the commands you use most frequently are close at hand. Sometimes it isn’t 
always intuitive as to what tab certain functions are listed under, but overall the Ribbon 
is a great enhancement to Office 2007. Until you get used to the Ribbon, you will think 
that Microsoft hid things from you. For instance, you would think that Spell Check is 
under the References tab, but it is not. It is under the Review tab. 

 

Here are some ways to make the Ribbon work better for you:  
• Click the Launcher in the bottom right corner of a group to launch the dialog box 

or task pane for those group tasks.  
• To display only the tabs in the Ribbon, right-click in the Ribbon and select 

Minimize the Ribbon from the resulting menu.  
• To swap placement of the Quick Access toolbar and the Ribbon, right-click in the 

Ribbon and select Show Quick Access Toolbar Below the Ribbon from the 
resulting menu.  

If you are new to Office 2007, you know it is quite different. The use of the Ribbon is 
handy, but you have to know what kind of tool is under which heading. You would think 
that Spell Check is under the References tab, but it is not. To access Spelling & 
Grammar Check, as well as Research, Thesaurus, Translation, and Word Count, click 
on the Review tab and click a button in the Proofing group. If you want to make it even 
easier to find, right-click the Spelling & Grammar button and select Add to Quick 
Access toolbar from the resulting menu. 

It is now time to get familiar with the new look of Word 2007.  
Start a new Word document by clicking on the Start button at the bottom 
left-hand corner of your desktop.    
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Now, let’s take a closer look at the Ribbon! As you look at each tab, roll your mouse 
over each button to see the ScreenTips; this will name the button and describe its 
functions. 

1. The Home tab contains buttons related to working with document content and 
are organized in five groups: Clipboard, Font, Paragraph, Styles, and Editing.  

 

2. The Insert tab contains buttons related to all the items you can insert and are 
organized in seven groups: Pages, Tables, Illustrations, Links, Header & Footer, 
Text, and Symbols.  

 

3. The Page Layout tab contains buttons related to the appearance of your 
document and are organized in five groups: Themes, Page Setup, Page 
Background, Paragraph, and Arrange. 

 

4. The References tab contains buttons related to items you can add to long 
documents such as reports; they are organized in six groups: Table of Contents, 
Footnotes, Citations & Bibliography, Captions, Index, and Table of Authorities.  
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5. The Mailings tab contains buttons related to mass mailings and are organized in 
five groups: Create, Start Mail Merge, Write & Insert Fields, Preview Results, and 
Finish.  

 

6. The Review tab contains buttons related to proofing, commenting, and changing 
documents; they are organized in six groups: Proofing, Comments, Tracking, 
Changes, Compare, and Protect. 

 

7. The View tab contains buttons related to changing the view or the display of 
documents; they are organized in five groups: Document Views, Show/Hide, 
Zoom, Window, and Macros. 
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Word 2007 Basics 
 
Creating a New Document 
 

1. Click the Microsoft Office Button, and then click New. 
2. Double-click Blank document.  

 
Or Start a Document from a Template 
 

1. Click the Microsoft Office Button, and then click New. 
2. Under Templates, do one of the following:  

a. Click Installed Templates to select a template that is available on 
your computer.  

b. Click one of the links under Microsoft Office Online, such as 
Flyers or Letters and Letterhead.  

3. Double-click the template that you want.  
 
Saving a Document 
To keep your work, you have to save it, and it’s never too early to do that. 

1. To save a document for the first time, either click the Save icon  on the Quick 

Access Toolbar or click the Microsoft Office Button  and then click Save, 
or press CTRL + S.  

2. In the Save As dialog box, choose a location to save the document. 
• In Windows Vista, select a location to save the document in the Address 

Bar at the top of the dialog box. It defaults to Documents or the last place 
you saved a Word document.  

• In Windows XP, select a location to save the document in the Save In list 
at the top of the dialog box.  

3. Enter a name for the document in the File name box. 
4. The Save as type box should say Word document (*.docx file extension).  
5. Click Save. 

Vista Window 

 
 



Resource of CPSB Technology Department    
Technology Training Center
 

  Page 6 

Closing a Document 
When you are through with a document and have saved your work, close the file.  

• Click the Microsoft Office Button , and then click Close. 

• Click the Microsoft Office Button , and then click Exit Word in the lower 
right-hand corner. 

 
Opening a Document 
If you already have a Word document that you want to open, there are several ways to 
open it.  

• To see a list of the documents opened most recently, click the Microsoft Office 

Button . Click any document in the Recent Documents list to open it. If you 
use a document frequently, there is even a way to pin it to the Recent 
Documents list.  

• Click the Microsoft Office Button , and then click Open. The Open dialog 
box will appear. The first time the Open dialog box is used, it will default to the 
Documents folder. If you use it again in the same Word session, it will open in the 
last location used.  

• CTRL + O will also open the Open dialog box so you can browse to the 
document that you want to open. 

Quick Tip: Documents created with previous versions of Word can be opened with 
Word 2007. The name of the document appears in the title bar with Compatibility 
Mode to its right. Compatibility Mode ensures that no new or enhanced features in 
Office Word 2007 are available while you are working with a document, so that people 
who are using previous versions of Word will have full editing capabilities. You can work 
in Compatibility Mode or you can convert your document to the Office Word 2007 file 
format. The Word Convert command clears the compatibility options so that the 
document layout appears as it would if it had been created in Word 2007. If the file is in 
.doc format, the Convert command also upgrades the file to the .docx format. 
 
Converting your document allows access to the new and enhanced features in Office 
Word 2007. However, people who are using previous versions of Word may be 
prevented from or have difficulty editing certain portions of the document that were 
created by using new or enhanced features in Office Word 2007. Anyone trying to read 
Office 2007 with previous versions of Word will have to install the Compatibility Pack 
for Office 2007 (available for free download from Microsoft Office Online).  

To convert the document, click on the Microsoft Office Button  and click Convert.    
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Changing Page Margins 
If you are changing the margins for a whole document that is divided into sections, 
press CTRL+A to select the entire document before you begin. 

1. On the Page Layout tab, in the Page Setup group, click Margins.  

 

2. Do one of the following:  
• Click the margin type that you want. For the most common margin 

width, click Normal.  
• Click Custom Margins, and then in the Top, Bottom, Left, and 

Right boxes, enter new values for the margins.  
 
Changing the Default Margins 
You can change the default margins that Microsoft Office Word uses for all new blank 
documents. 

1. After you select a new margin for the document, click Margins in the Page 
Setup group again, and then click Custom Margins.  

2. In the Page Setup dialog box, click Default.  
The new default settings are saved in the template on which the document is based. 
Each new document based on that template automatically uses the new margin 
settings.  
 
Quick Tip: If all you want to do is get to the Page Setup dialog box, double-click in the 
margin part on the ruler at the top of your document. Your ruler must be selected in 
order for it to show up. That setting is under the View tab in the Show/Hide group.  
 
Changing Line Spacing 
If a line contains a large text character, graphic, or formula, Microsoft Office Word 
increases the spacing for that line. 

1. Select the paragraph for which you want to change the line spacing. 
2. On the Home tab, in the Paragraph group, click Line Spacing.  

 

 
3. Do one of the following:  

• To apply a new setting, click the number of line spaces that you want.  
• For example, if you click 1.0, the selected text is single-spaced. 
• To set more precise spacing measurements, click Line Spacing Options, 

and then select the options that you want under Line spacing.  
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Line Spacing Options 
• Single:  This option accommodates the largest font  in that line, plus a 

small amount of extra space. The amount of extra space varies depending 
on the font that is used.  

• 1.5 lines:  This option is one-and-one-half times that of single-line 
spacing.  

• Double:  This option is twice that of single line spacing.  
• At least:  This option sets the minimum line spacing that is needed to fit 

the largest font or graphic on the line.  
• Exactly:  This option sets fixed line spacing that Word does not adjust.  
• Multiple:  This option sets line spacing that is increased or decreased 

from single spacing by a percentage that you specify. For example, setting 
line spacing to 1.2 will increase the space by 20 percent.  

 
Working with Text 
Inserting Text  

1. Once you have a new document open in Word, you can immediately begin 
inputting text by clicking within the document window and typing.  

2. The font, font color, font style, font size, and line spacing will vary depending on 
any customizations that have been set as default.  

3. Text will appear at the location of the cursor and will wrap to the next line. 
4. Pressing the Enter key will end the paragraph and you can begin typing on the 

next line.  
 
Selecting and Deselecting Text 

1. Place the pointer in front of the text you wish to select.   
2. The pointer will turn into an I-beam pointer. 
3. Hold down the left mouse button and pass the pointer over the text you wish to 

select. Selected text appears highlighted on the screen. 
4. Release the mouse button when you have selected all the text. You may now 

copy or cut the text or apply other changes to the selected text. 
5. To deselect text, simply click anywhere in the document away from the selected 

text. 
 
Deleting Text 

1. Select the text you wish to delete and press the Delete key. 
OR 

2. If you only want to delete a few characters, place the cursor either in front or 
behind the characters you wish to delete. Then press the Backspace key (to 
delete backwards) or the Delete key (to delete forward). 

 
Quick Tips: You can select specific items like words, sentences, or paragraphs with 
just a few clicks of the mouse. 

• To select a word, double-click it. 
• To select a sentence, click anywhere in the sentence while holding the CTRL 

key. 

javascript:AppendPopup(this,'offont_2_2')
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• To select a paragraph, triple-click it. 
• To select adjacent words, click in front or behind the words and then hold Shift 

key and use the arrow keys or click at the end of the text you wish to select.  
 
More Quick Tips: You can also select various items by utilizing the selection area (an 
invisible area in the left margin. 

• To select a line, click the selection area to the left of the line.  
• To select a paragraph, double-click the selection area to the left of the 

paragraph. 
• To select an entire document, triple-click the selection area. 

 
Moving the Insertion Point 
Sometimes you will want to move the insertion point quickly from the beginning to the 
end.  Press Ctrl + Home OR Ctrl + End.  
 
Moving or Copying Text and Graphics 

1. Select the item you want to move or copy.  
2. Do one of the following:  

• To move the item, press CTRL+X, OR use the Cut icon  on the Home 
tab in the Clipboard group. 

• To copy the item, press CTRL+C, OR use the Copy icon on the Home 
tab in the Clipboard group.  

3. If you want to move or copy the item to another document, switch to that 
document, OR use the Clipboard.  

4. Click where you want the item to appear.  

• Press CTRL+V, OR use the Paste icon  on the Home tab in the Clipboard 
group.   

5. To adjust the format of the items that are pasted, click the Paste Options button 
that appears just below your pasted selection, and then click the option that 

you want.  
 
Using the Clipboard 
When you need to move or copy text between two locations or two documents that you 
can’t see at the same time, you may want to use the clipboard.  

1. Select the text, and then click the Cut or Copy icon on the Home tab in the 
Clipboard group.  

2. You can place up to 24 items, text or graphics, in the clipboard. These items can 
be pasted elsewhere in the document, on another document, or in another Office 
program either individually, in multiples, or all at once by opening up the 
clipboard, selecting the items, and pasting them in wherever they need to be.  
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Undoing Mistakes 
1. On the Quick Access Toolbar, point to Undo . Word displays the most recent 

action that you can undo. 
2. Click Undo or press CTRL + Z. If you want to undo a different action, click the 

arrow next to Undo , and then click the action in the list of most recent actions. 
When you undo an action, you also undo all actions above it in the list. 

 
Quick Tip: If you later decide you didn't want to undo an action, click Redo on the 
Quick Access Toolbar or press CTRL+Y.  
 
Overtyping 
In previous versions of Word, it was possible to switch from Insert mode to Overtype 
mode by accidentally hitting the Insert key. In Overtype mode existing text does not 
move to the right when you type new text. Each character you type replaces existing 
characters. In Word 2007, you must deliberately switch to Overtype mode. 

1. Right-click the status bar and then click Overtype to display the Insert mode 
status at the left end of the status bar.  

2. Click Insert on the status bar. The word Overtype then replaces Insert. You can 
click the word to switch back when you are finished with Overtyping. 

 
 
Adding and Deleting Pages 
Adding a Page 

1. Click where you want to insert a new page in your document. The inserted page 
will appear just before your cursor. 

2. On the Insert tab, in the Pages group, click Blank Page.  

 
 
Combining Two Pages 
You can combine two pages by placing your cursor between the two pages and 
pressing BACKSPACE. 
 
Deleting a Blank Page 
Do one of the following: 

• To delete a blank page in your document, put your cursor at the start of the page 
that you want to delete, and then press BACKSPACE.  

• To delete a blank page at the end of the document, go to the end of the 
document and delete any extra paragraph marks. If you still see a page break, 
select the page break, and then press DELETE.  
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Note: Make sure that you are in Draft view (on the View tab, in the Document Views 
group, click Draft). If paragraph markers (¶), are not visible, click Show/Hide in the 
Paragraph group on the Home tab. Draft view is the view that shows text formatting 
and a simplified page layout. Draft view is convenient for most editing and formatting 
tasks. 
 
Editing Documents 
Revising Words Underlined in Red, Green, or Blue 
If you are a Word user, you may or may not know about the red and green wavy lines 
under words; but, what is that blue wavy line all about in Word 2007? Word enters a 
wavy red underline under misspelled words or under words it does not recognize. A 
wavy green underline under text means that Word thinks the grammar should be 
revised. A blue underline means a word may not be the correct word in the sentence.  
 
Any time you see an underlined word, simply right-click the word that is underlined, 
and then select a suggested revision. Your selection will replace the underlined word, 
and the underline will go away. It is rare that Word will not offer suggestions for 
alternatives…unless it is a proper noun like a name. If you enter something that is 
correctly spelled but Word doesn’t recognize it, you can always right-click on it, and then 
click Add to Dictionary.  
 
Quick Tip: Word is really good at spelling most of the time. However, grammar and 
correct word usage will take some judgment and knowledge from the user. You can 
click Ignore or Ignore All to ignore suggested revisions and get rid of the underlines. 
Those selections will only apply to the current document.  
 
If the wavy lines don’t drive you crazy, you can always ignore the lines and just check 
spelling and grammar all at once when you are done. To do this, you simply click on the 
Review tab and click Spelling & Grammar in the Proofing group. 
 
Quick Tip: Word also has a Spelling and Grammar Check quick button on the status 
bar at the bottom of the Word window. It looks like a book, and it either shows a check 
mark or a red X on it. The red X means that Word thinks there are errors that need to be 
corrected.  

  = No proofing errors 
 

  = Proofing errors were found. Click to correct.  
 
Finding the Right Word 
Using the Research feature, you can look up synonyms (different words with the same 
meaning) and antonyms (words with the opposite meaning) in the thesaurus. 

1. On the Review tab, click Thesaurus. 
2. Press ALT and click the word that you want to look up. Results appear in the 

Research task pane.  
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3. To use one of the words in the list of results or to search for more words, do one 
of the following:  
• To use one of the words, point to it, click the down arrow, and then click 

Insert or Copy. 
• To look up additional related words, click a word in the list of results. 

 
Quick Tip: You can look up a word quickly if you right-click anywhere in the document, 
and then click Synonym on the shortcut menu. 
 
Getting Help  

To find out how to do something, click the Microsoft Office Word Help button   in the 
upper-right corner of the Word window. Then type your question in the Type words to 
search for box, next to Search.  
 

 
 
 
 
 
Adding Basic Formatting, Styles, and Themes 
Office Word 2007 offers easy ways to change formatting in a document, including fonts 
and styles. However, for a professional looking document in very little time, you can use 
themes that choose the right combination of fonts and colors for you. 
 
Changing the Text Size 
In Office Word 2007, you can use the formatting options Mini toolbar to quickly format 
text. The Mini toolbar appears automatically when you select text. It also appears with 
the menu when you select text and then right-click. 
 

1. Select the text that you want to change, and then move your pointer to the Mini 
toolbar that appears with your text selection. 

  
2. Do one of the following:  

 To make the text larger, click Grow Font, or press CTRL+SHIFT+>.  
 To make the text smaller, click Shrink Font, or press CTRL+SHIFT+<.  

 
Quick Tip: You can also change the font size in the Font group on the Home tab. 
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Applying a Style 
Applying a style to a selection of text in Office Word 2007 is as easy as clicking a button 
on the Mini toolbar that appears when you select text. 
 

1. Select the text to which you want to apply a style.  
For example, you can select text that you want to make into a heading. If you 
want to change the style for an entire paragraph, click anywhere in the 
paragraph. 

2. Move your pointer to the Mini toolbar that appears with your text selection, click 
to open the Quick Styles gallery, and then click the style that you want.  

 
For example, if you select text that you want to style as a title, click the style 
called Title in the Quick Styles gallery.  
 

Quick Tip: Don’t forget! If you point to a thumbnail in a gallery, live preview shows you 
what the choice will look like if you apply it.  
 
Reusing Formatting 
Use the Format Painter to copy the text formatting from one area of a document and 
apply it to another area. 
 

1. Select the text that has the formatting that you want to apply to other areas.  
2. On the Home tab, in the Clipboard group, click Format Painter. 

 
 
 
 
 
 
 
Note: To apply the text format to multiple areas, double-click Format Painter. 
When you finish applying formatting, click Format Painter again, or press ESC. 
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Changing a Quick Style Set 
You can dramatically change the look of your document by changing the Quick Style set 
that you use. If you don't like the look of the styles you selected, you can either select a 
different set from the gallery of styles, or change a styles set to suit your preferences. 
 
Changing the Quick Style Set 
 

1. On the Home tab, in the Styles group, click Change Styles.  
 

 
 

2. Point to Style Set, and then click the style set that you want, such as Formal.  
 

Quick Tip: You can preview any style set by pointing to the style set and previewing the 
styles changes in your document. 
 
Creating a New Quick Style 
Quick Styles are sets of styles that are created to work together. Although a Quick Style 
set likely contains all of the styles that you need to build a document, you may want to 
add a new style. You can also create additional styles, such as a new table or list style. 
 

1. Select the text that you want to create as a new style.  
For example, perhaps you want the word homework to always appear as bold 
and red in your document. 

2. On the Mini toolbar that appears above your selection, click Bold and Red to 
format the text.  

3. Right-click the selection, click Styles, and then click Save Selection as a New 
Quick Style.  

4. Give the style a name — for example, homework — and then click OK.  
 
The homework style that you created appears in the Quick Styles gallery with the name 
that you gave it, ready for you to use whenever you want text to be bold and red. 
 
Quick Tip: You may want to block users from changing the default Quick Style set. If 
so, here’s how: 

1. On the Home tab, in the Styles group, click the Styles Dialog Box Launcher. 
 
 
 
 
 

 



Resource of CPSB Technology Department    
Technology Training Center
 

  Page 15 

2. In the Styles dialog box, click Manage Styles , and then click the Restrict 
tab.  

3. Select the Block Quick Style Set switching check box.  
Note: Restricting users from changing the Quick Style set does not prevent them 
from changing the font or color themes. 

 
 
Applying a Theme 
Theme changes are a way to refine and individualize the look of the Quick Styles set 
that you choose for your document. By experimenting with styles, fonts, and colors, you 
can find the look that works for your documents. 
 
Applying a Predefined Font Theme 
You can change the fonts in your document by selecting a new font theme. When you 
choose a new font theme, you change the heading and body text font for the document 
that you are working on. 
 

1. On the Home tab, in the Styles group, click Change Styles.  
 

 
 

2. Point to Fonts, and click the built-in font theme that you want to use.  
 
Creating a Custom Font Theme  

1. On the Page Layout tab, in the Themes group, click Theme Fonts.  
 

 
 

2. Click Create New Theme Fonts.  
3. Select the fonts and sizes that you want to use in the Heading font and Body 

font lists. The sample is updated with the fonts that you select. 
4. In the Name box, type a name for the new font theme.  
5. Click Save.  

 
  



Resource of CPSB Technology Department    
Technology Training Center
 

  Page 16 

Applying a Predefined Color Theme 
You can change the colors in your document by selecting a new color theme. When you 
choose a new color theme, Word automatically formats various parts of your document 
with colors that are designed to work together. 

1. On the Home tab, in the Styles group, click Change Styles.  
 

 
 

2. Point to Colors, and then click the color theme that you want to use.  
 

Quick Tip: If you have added a custom style with a color defined, changing the color 
theme may change the color of your custom style. 
 
Creating a Custom Color Theme 
When you apply a color theme and then change one or more of the colors in your 
document, those changes immediately affect the active document. If you want to apply 
the changes to new documents, you can save them as a custom color theme. 

1. On the Page Layout tab, in the Themes group, click Theme Colors.  

 
 

2. Click Create New Theme Colors.  
3. Under Theme colors, select the colors that you want to use. To see how colors 

that you select look in your document, click Preview. The sample in the Preview 
pane will change to show you a preview of your color selection. 

4. In the Name box, type a name for the new color theme.  
5. Click Save.  

 
Creating Lists 
Word can automatically create bulleted and numbered lists as you type, or you can 
quickly add bullets or numbers to existing lines of text. 
 
Typing a Bulleted or Numbered List 

1. Type * (asterisk) to start a bulleted list or type 1. to start a numbered list, and 
then press SPACEBAR or the TAB key.  

2. Type any text that you want.  
3. Press ENTER to add the next list item. Word automatically inserts the next bullet 

or number. 
4. To finish the list, press Enter twice, or press Backspace to delete the last bullet 

or number in the list.  
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If Bullets and Numbering Do Not Begin Automatically 

1. Click the Microsoft Office Button , and then click Word Options.  
2. Click Proofing.  
3. Click AutoCorrect Options, and then click the AutoFormat As You Type tab.  
4. Under Apply as you type, select the Automatic bulleted lists check box and 

the Automatic numbered lists check box.  
 
Adding Bullets or Numbering To a List 

1. Select the items that you want to add bullets or numbering to.  
2. On the Home tab, in the Paragraph group, click Bullets or Numbering.  
 

 
 

For more bullet styles and numbering formats, click the arrow next to Bullets or 
Numbering. 
Quick Tip: You can move an entire list to the left or the right. Click the first bullet or 
number in the list, and drag it to a new location. The entire list moves as you drag. 
 
Spreading Out the Items in a List 
You can increase the space between the lines in all of your lists by clearing a check 
box. 
 

1. On the Home tab, in the Styles group, click the arrow next to Styles, and then 
right-click the List Paragraph style.  

2. Click Modify.  
3. In the Modify Style dialog box, click Format, and then click Paragraph.  
4. Clear the Don't add space between paragraphs of the same style check box.  

 
Adding a Cover Page 
Office Word 2007 offers a gallery of convenient predesigned cover pages. Choose a 
cover page and replace the sample text with your own. 
Cover pages are always inserted at the beginning of a document, no matter where the 
cursor appears in the document. 
 

1. On the Insert tab, in the Pages group, click Cover Page.  
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2. Click a cover page layout from the gallery of options. After you insert a cover 

page, you can replace the sample text with your own text. 
 
Quick Tips:   

• If you insert another cover page in the document, it will replace the first cover 
page you inserted.  

• If you created the cover page in an earlier version of Word, you can't replace the 
cover page with a design from the Office Word 2007 gallery.  

• To delete a cover page, click the Insert tab, click Cover pages in the Pages 
group, and then click Remove Current Cover Page.  

 
Displaying Different Views 
There are several ways to view a document:  
 

• Print Layout View: displays a document the way it will look when printed.  
• Full Screen Reading View: displays as much of the content as will fit on the 

screen that is comfortable for reading. 
• Web Layout View: displays a document the way it will be viewed in a Web 

browser.  
• Outline View: displays the structure of a document as nested levels of headings 

and body text, and provides tools for viewing and changing its hierarchy. 
 
Inserting Clip Art or Pictures  
Pictures and clip art can be inserted or copied into a document from many different 
sources, including downloaded from a clip art Web site provider, copied from a Web 
page, or inserted from a file where you save pictures. 

Inserting Clip Art 
1. On the Insert tab, in the Illustrations group, click Clip Art. 

 
 
 
 
 

2. In the Clip Art task pane, in the Search for text box, type a word or phrase that 
describes the clip art that you want, or type in all or some of the file name of the 
clip art.  

3. To narrow your search, do one or both of the following: 
• To limit the search results to a specific collection of clip art, in the Search 

in box, click the arrow and select the collection you want to search.  
• To limit the search results to clip art, click the arrow in the Results should 

be box and select the check box next to Clip Art. 
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4. In the Clip Art task pane, you can also search for photographs, movies, and 
sounds. To include any of those media types, select the check boxes next to 
them. 

5. Click Go.  
6. In the list of results, click the clip art to insert it. 

Note: The lone picture toolbar that used to pop out when you clicked on clip art no 
longer exists. Instead, when you click on a picture, you should see a Drawing Tools tab 
appear above the Format tab on the Ribbon.  
 

 
 
Inserting a Picture from a File 

1. Click where you want to insert the picture.  
2. On the Insert tab, in the Illustrations group, click Picture. 

 
 
 
 
 

3. Locate the picture that you want to insert.  
4. Double-click the picture that you want to insert. 

 
Note: The lone picture toolbar that used to pop out when you clicked on a picture no 
longer exists. Instead, when you click on a picture, you should see a Picture Tools tab 
appear above the Format tab on the Ribbon.  
 

 
 
Inserting More Common Features 
 
Inserting WordArt 
WordArt is a text-styling feature that allows users to create stylized text with various 
"special effects" such as textures, outlines, and many other manipulations that are not 
available through the standard font formatting.  
 

1. Click where you want to insert the WordArt.  
2. On the Insert tab, in the Text group, click WordArt. 
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3. Locate the style that you want to insert. You can always format the colors later.  
4. Type in the text that you want in WordArt. Click OK. 
5. To change formatting, colors, add effects, or anything else for WordArt, click on 

the WordArt text to access the WordArt tools.  
 
Note: The lone WordArt toolbar that used to pop out when you clicked on WordArt no 
longer exists. Instead, when you click on any WordArt, you should see a WordArt 
Tools tab appear above the Format tab on the Ribbon.  
 

 
 
 
Inserting a Watermark 
With watermarks, you can add a new layer of information to your documents.  You can 
add text watermarks, such as Draft or Confidential, to your document. Microsoft Office 
Word 2007 provides galleries of ready-made watermarks, or you can create your own 
custom watermark, such as a company logo. Or you can add a background color or 
picture to your document. 
 

1. On the Page Layout tab, in the Page Background group, click Watermark. 

 
 

2. Do one of the following:  
• Click a predesigned watermark, such as Confidential or Urgent, in the 

gallery of watermarks.  
• Click Custom Watermark, click Text watermark and then select or type 

the text that you want. You can also format the text.  
3. To view a watermark as it will appear on the printed page, use Print Layout view. 

 
Inserting a Page Background 

1. On the Page Layout tab, in the Page Background group, click Page Color. 
2. Do any of the following:  

• Click the color that you want under Theme Colors or Standard Colors.  
• Click Fill Effects to change or add special effects, such as gradients, 

textures, or patterns.  
Note: Select the color that you want before you apply a gradient or pattern. 
 
 



Turning a Picture into a Background or Watermark 
You can turn a picture, clip art, or a photo into a watermark that you can use to brand or 
decorate a document. 

1. On the Page Layout tab, in the Page Background group, click Watermark. 
2. Click Printed Watermark.  
3. Click Picture watermark, and then click Select Picture.  
4. Select the picture that you want, and then click Insert.  
5. Select a percentage under Scale to insert the picture at a particular size  
6. Select the Washout check box to lighten the picture so that it doesn't interfere 

with text.  
The picture that you selected is applied as a watermark to the entire document. 
 
Quick Tip: If you want to use an object, such as a shape, as a watermark, you can 
manually paste or insert it into the document. You cannot use the Printed Watermark 
dialog box to control settings for these objects. 
 
 
 
 
 
 
 
 
 
 
 
 
This handout does not cover everything that Word 2007 can do, only some of the 
basics. There is so much more you can do with Word. In fact, Microsoft offers webcasts, 
demos, and more. Find more information on Word 2007 at the following websites listed 
below: 
 
Resources: 
Microsoft Word 2007 Training Courses  
http://office.microsoft.com/en-us/training/HA102155661033.aspx  
 
Microsoft Word Demos 
http://office.microsoft.com/en-us/word/CH100740901033.aspx  
 
Microsoft Online Help for Word 2007 
http://office.microsoft.com/en-
us/word/FX100649251033.aspx?CTT=96&Origin=CL100636481033  
 
Word Tips: 
http://www.microsystems.com/resources/word-tips-and-tricks.php  
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